<!doctype html>
<html lang="en-US" class="no-js">
  <head>
    <style type="text/css">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</style>    <meta charset="UTF-8">
    <title>Bots on Botwiki | Botwiki</title>
    <meta itemprop="name" content="Bots on Botwiki | Botwiki"/>
    <meta itemprop="url" content="https://botwiki.org/bots"/>
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="/feed" />
    <meta property="og:title" content="Bots on Botwiki | Botwiki" />
    <meta name="twitter:title" content="Bots on Botwiki | Botwiki" />
    <meta name="description" content="Browse bots on Botwiki." />
    <meta property="og:description" content="Browse bots on Botwiki." />
    <meta name="twitter:description" content="Browse bots on Botwiki." />
    <meta property="og:type" content="website" />
    <meta property="og:url" content="https://botwiki.org/bots" />
        <meta property="og:image" content="https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png" /> 
    <meta property="twitter:image:src" content="https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png" /> 
        <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:site" content="@botwikidotorg" />
    <meta name="twitter:domain" content="https://botwiki.org/" />
    <link type="text/plain" rel="author" href="https://botwiki.org/humans.txt" />
    <link href="//www.google-analytics.com" rel="dns-prefetch">
    <link rel="apple-touch-icon" sizes="57x57" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-57x57.png">
    <link rel="apple-touch-icon" sizes="60x60" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-60x60.png">
    <link rel="apple-touch-icon" sizes="72x72" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-72x72.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="114x114" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-114x114.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-120x120.png">
    <link rel="apple-touch-icon" sizes="144x144" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-144x144.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/apple-icon-180x180.png">
    <link rel="icon" type="image/png" sizes="192x192"  href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/android-icon-192x192.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/favicon-32x32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/favicon-96x96.png">
    <link rel="icon" type="image/png" sizes="16x16" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/favicon-16x16.png">
    <link rel="manifest" href="https://botwiki.org/wp-content/themes/botwiki/images/favicons/manifest.json">
    <meta name="msapplication-TileColor" content="#ffffff">
    <meta name="msapplication-TileImage" content="/ms-icon-144x144.png">
    <meta name="theme-color" content="#38313a">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <!--
    <link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" href='https://fonts.googleapis.com/css?family=Fira+Sans:400,700|Open+Sans|Source+Serif+Pro|Source+Code+Pro&display=swap' rel='stylesheet' type='text/css'>
    <link href='https://fonts.googleapis.com/css?family=Fira+Sans:400,700|Open+Sans|Source+Serif+Pro|Source+Code+Pro&display=swap' rel='stylesheet' type='text/css'>
    <link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" href='https://fonts.googleapis.com/css?family=Bree+Serif&text=botwiki&display=swap' rel='stylesheet' type='text/css'>
    <link href='https://fonts.googleapis.com/css?family=Bree+Serif&text=botwiki&display=swap' rel='stylesheet' type='text/css'>
    -->
    <script type="application/ld+json">
    {
      "@context": "https://schema.org",
      "@type": "NewsArticle",
      "headline": "Bots on Botwiki | Botwiki",
      "image": [
        "https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png"
       ],
      "datePublished": "January 28, 2018",
      "dateModified": "November 21, 2020"
    }
    </script>
    <style type="text/css">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</style>        <!-- <script defer src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> -->
  <meta name='robots' content='max-image-preview:large' />
<link rel="author" type="text/plain" href="https://botwiki.org/humans.txt" />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/botwiki.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='wp-block-library' href='https://botwiki.org/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library' href='https://botwiki.org/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' /><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='wp-bootstrap-blocks-styles' href='https://botwiki.org/wp-content/plugins/wp-bootstrap-blocks/build/style-index.css?ver=3.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-bootstrap-blocks-styles' href='https://botwiki.org/wp-content/plugins/wp-bootstrap-blocks/build/style-index.css?ver=3.1.3' type='text/css' media='all' /><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='ftf-ate-frontend-styles' href='https://botwiki.org/wp-content/plugins/tembeds/dist/css/styles.min.css?ver=1620248897' type='text/css' media='all' />
<link rel='stylesheet' id='ftf-ate-frontend-styles' href='https://botwiki.org/wp-content/plugins/tembeds/dist/css/styles.min.css?ver=1620248897' type='text/css' media='all' /><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='wp-rest-filter' href='https://botwiki.org/wp-content/plugins/wp-rest-filter/public/css/wp-rest-filter-public.css?ver=1.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-rest-filter' href='https://botwiki.org/wp-content/plugins/wp-rest-filter/public/css/wp-rest-filter-public.css?ver=1.4.3' type='text/css' media='all' /><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='select2-styles' href='https://botwiki.org/wp-content/themes/botwiki/libs/select2/4.0.10/css/select2.min.css?ver=1617732178' type='text/css' media='all' />
<link rel='stylesheet' id='select2-styles' href='https://botwiki.org/wp-content/themes/botwiki/libs/select2/4.0.10/css/select2.min.css?ver=1617732178' type='text/css' media='all' /><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='styles' href='https://botwiki.org/wp-content/themes/botwiki/css/styles.min.css?ver=1620056668' type='text/css' media='all' />
<link rel='stylesheet' id='styles' href='https://botwiki.org/wp-content/themes/botwiki/css/styles.min.css?ver=1620056668' type='text/css' media='all' /><script type='text/javascript' defer="defer" src='https://botwiki.org/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/themes/botwiki/libs/bootstrap/bootstrap.min.js?ver=1617732178' id='bootstrap-js-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/themes/botwiki/libs/tilt/tilt.jquery.min.js?ver=1617732178' id='tilt-js-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/themes/botwiki/libs/js-cookie/js.cookie-2.2.1.min.js?ver=1617732178' id='js-cookie-js-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/themes/botwiki/libs/select2/4.0.10/js/select2.min.js?ver=1617732178' id='select2-js-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/themes/botwiki/js/scripts.min.js?ver=1617732178' id='scripts-js'></script>
<script type='text/javascript' id='email-posts-to-subscribers-js-extra'>
/* <![CDATA[ */
var elp_data = {"messages":{"elp_name_required":"Please enter name.","elp_email_required":"Please enter email address.","elp_invalid_name":"Name seems invalid.","elp_invalid_email":"Email address seems invalid.","elp_unexpected_error":"Oops.. Unexpected error occurred.","elp_invalid_captcha":"Robot verification failed, please try again.","elp_invalid_key":"Robot verification failed, invalid key.","elp_successfull_single":"You have successfully subscribed.","elp_successfull_double":"You have successfully subscribed. You will receive a confirmation email in few minutes. Please follow the link in it to confirm your subscription. If the email takes more than 15 minutes to appear in your mailbox, please check your spam folder.","elp_email_exist":"Email already exist.","elp_email_squeeze":"You are trying to submit too fast. try again in 1 minute."},"elp_ajax_url":"https:\/\/botwiki.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/plugins/email-posts-to-subscribers//inc/email-posts-to-subscribers.js?ver=2.2' id='email-posts-to-subscribers-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/plugins/wp-rest-filter/public/js/wp-rest-filter-public.js?ver=1.4.3' id='wp-rest-filter-js'></script>
<link rel="https://api.w.org/" href="https://botwiki.org/wp-json/" /><link rel="alternate" type="application/json" href="https://botwiki.org/wp-json/wp/v2/pages/57" /><link rel="alternate" type="application/json+oembed" href="https://botwiki.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbotwiki.org%2Fbots%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://botwiki.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbotwiki.org%2Fbots%2F&#038;format=xml" />
<style>.elp_form_message.success { color: #008000;font-weight: bold; } .elp_form_message.error { color: #ff0000; } .elp_form_message.boterror { color: #ff0000; } </style><script type="text/javascript">
	window._se_plugin_version = '8.1.9';
</script>
  </head>
  <body class="page-template-default page page-id-57 page-parent bots">
    <noscript><style type="text/css">.lazy-load{opacity:1;transform:none;}</style></noscript>
    <header id="header">
          <nav class="navbar navbar-expand-md fixed-top">
        <div class="container-fluid">
          <div class="row m-0 w-100">
            <div class="col-sm-6">
              <label id="menu-icon" class="cursor-pointer botwiki-logo" for="menu-toggle">b</label>
            </div>
            <div class="col-sm-6 text-right pr-0">
            </div>
          </div>
        </div>
        <input type="checkbox" id="menu-toggle">
        <div id="menu-wrapper" class="container-fluid">
            <div class="row w-100">
    <div class="col-sm-12 pl-0 pr-0">
      <div class="container menu-container pl-0 pr-0 m-0">
<div class="row">
<div class="col-sm-12 col-md-8">
<h1 class="botwiki-logo">bot<br class="d-block d-sm-none">wiki</h1>
</div>
<div class="col-sm-12 col-md-4 hover-box">
    <a href="/bots/">
<h2>explore</h2>
What are bots, and where to find them.
<div class="hover-icon">🤖</div>
</a></div>
<div class="col-sm-12 col-md-4 hover-box">
    <a href="/resources/">
<h2>create</h2>
Learn how to make fun, friendly online bots.
<div class="hover-icon">🔧</div>
</a></div>
<div class="col-sm-12 col-md-4 hover-box">
    <a href="/learn/">
<h2>learn</h2>
Read our collection of articles and essays.
<div class="hover-icon">📚</div>
</a></div>
<div class="col-sm-12 col-md-4 hover-box">
    <a href="/about/">
<h2>about</h2>
What is Botwiki, and who made it.
<div class="hover-icon">❓</div>
</a></div>
</div>
</div>    </div>
        <div class="col-sm-12 pt-4 pr-4 pl-4 pb-4">
      <div itemscope itemtype="https://schema.org/WebSite">
  <link itemprop="url" href="https://botwiki.org/"/>
  <form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" class="form mt-5 mt-md-0 mb-5 text-right pr-0 w-100" method="get" action="https://botwiki.org" role="search">
    <meta itemprop="target" content="https://botwiki.org/?s={s}"/>
    <div class="container mt-3 pl-0 pr-0 text-left">
      <div class="row w-100 pl-1 pr-1">
        <div class="col-sm-12 mt-2 pl-0 pr-0">
          <input itemprop="query-input" required pattern="\s*(\S\s*){2,}" title="What would you like to search for?" id="search-input" class="form-control mt-3 mb-3 mr-sm-2" type="search" name="s" placeholder="Search..." aria-label="Search" value="">
        </div>
      </div>
    </div>  
    <div id="search-filters" class="container mt-1 pl-0 pr-0 text-left slide-up-hidden">
      <div class="row w-100 pl-1 pr-1">
        <div class="col-sm-12 mt-2 pl-1 pr-1">
          <div class="form-check form-check-inline d-xs-block">
            <input class="form-check-input" type="radio" id="search-filters-bots" name="search-filters-options[]" value="bots">
            <label class="form-check-label" for="search-filters-bots">Bots</label>
          </div>
          <div class="form-check form-check-inline d-xs-block">
            <input class="form-check-input" type="radio" id="search-filters-tutorials" name="search-filters-options[]" value="tutorials">
            <label class="form-check-label" for="search-filters-tutorials">Tutorials</label>
          </div>
          <div class="form-check form-check-inline d-xs-block">
            <input class="form-check-input" type="radio" id="search-filters-resources" name="search-filters-options[]" value="resources">
            <label class="form-check-label" for="search-filters-resources">All resources</label>
          </div>
          <div class="form-check form-check-inline d-xs-block">
            <input class="form-check-input" type="radio" id="search-filters-everything" name="search-filters-options[]" value="everything" checked>
            <label class="form-check-label" for="search-filters-everything">Everything</label>
          </div>
        </div>
        <div class="col-sm-12 mt-4 pl-1 pr-1">
          <div class="form-row">
            <label for="bot-info-1-network">Network</label>
            <select class="form-control js-select2" name="networks" placeholder="Twitter, Tumblr, Slack, …" data-minimum-input-length="0" data-clear="true" data-multiple="true" data-tags="false">
                            <option  value="aim-bots">Aim</option>
                              <option  value="computer-program">Computer program</option>
                              <option  value="discord">Discord</option>
                              <option  value="facebook-messenger-bots">Faccebook Messenger</option>
                              <option  value="facebook-bots">Facebook</option>
                              <option  value="facebook-messenger">Facebook Messenger</option>
                              <option  value="fediverse">Fediverse</option>
                              <option  value="github">GitHub</option>
                              <option  value="google-home">Google Home</option>
                              <option  value="instagram-bots">Instagram</option>
                              <option  value="irc">IRC</option>
                              <option  value="kik-bots">Kik</option>
                              <option  value="mastodon">Mastodon</option>
                              <option  value="msn">MSN</option>
                              <option  value="pleroma">Pleroma</option>
                              <option  value="reddit-bots">Reddit</option>
                              <option  value="skype">Skype</option>
                              <option  value="slack-bots">Slack</option>
                              <option  value="snapchat-bots">Snapchat</option>
                              <option  value="soundcloud">Soundcloud</option>
                              <option  value="telegram-bots">Telegram</option>
                              <option  value="tumblr-bots">Tumblr</option>
                              <option  value="twitch">Twitch</option>
                              <option  value="twitter-bots">Twitter</option>
                              <option  value="usenet">Usenet</option>
                              <option  value="web">Web</option>
                              <option  value="youtube-bots">YouTube</option>
               
            </select>
          </div>
        </div>
        <div class="col-sm-12 mt-4 pl-1 pr-1">
          <div class="form-row">        
            <label><input id="search-filter-opensource" name="opensource" type="checkbox" value="true" > Open-source</label>
          </div>
        </div>
        <div class="col-sm-12 mt-4 pl-1 pr-1">
          <div class="text-left">
            <button class="btn btn-outline-success my-2 my-sm-0 mx-n1" type="submit" role="button">Search</button>
          </div>
        </div>
      </div>
    </div>
  </form>
</div>    </div>
      </div>
        </div>
      </nav>
      </header>
  <!-- header -->
	<main role="main" class="container">
  <div class="mt-5">
				<!-- post title -->
		<h1 class="text-center post-title mt-5"><span              style="box-shadow: inset 0 -20px 0 0 rgba(4,41,48,0.44509085997254)"
            >Bots on Botwiki</span></h1>
		<!-- /post title -->
		  </div>

                    <div class="thumbnail-wrapper" style="background-color:rgb(4,41,48)">
            <a href="https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png">
              <img src="https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png" class="lazy-load expand-image webfeedsFeaturedVisual wp-post-image" alt="Bots galore!" loading="lazy" data-src="" title="Bots galore!" srcset="https://botwiki.org/wp-content/uploads/2018/03/bots-galore.png 1300w, https://botwiki.org/wp-content/uploads/2018/03/bots-galore-250x96.png 250w, https://botwiki.org/wp-content/uploads/2018/03/bots-galore-768x295.png 768w, https://botwiki.org/wp-content/uploads/2018/03/bots-galore-700x269.png 700w, https://botwiki.org/wp-content/uploads/2018/03/bots-galore-120x46.png 120w" sizes="(max-width: 1300px) 100vw, 1300px" />              <div class="image-border-shadow"></div>
            </a>
          </div>
          <!-- /post thumbnail -->
				            <!-- article -->
            <article id="post-57" class="post-content post-57 page type-page status-publish has-post-thumbnail hentry">
            <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><ul class="btn-list">
    <li><a class="btn" href="/new">What&rsquo;s new?</a></li>
    <li><a class="btn" href="#browse-bots-by-category">Browse by category</a></li>
    <li><a class="btn" href="#browse-bots-by-network">Browse by network</a></li>
    <li><a class="btn" href="/bot/">Browse all bots</a></li>
    <li><a class="btn" href="/random-bot">Random bot</a></li>
</ul>
<h4 id="bots"><a class="pilcrow-link" href="#bots"><span class="link">So what exactly is a &ldquo;bot&rdquo;?</span><span class="pilcrow">&para;</span></a></h4>
<p>Well, it really depends on <a href="/what-is-a-bot/">who you ask</a>:</p>
<blockquote>
    <div class="row">
        <div class="col-sm-12 col-md-6">
            <div>
                <p>An Internet bot, also known as web robot, WWW robot or simply bot, is a software application that runs automated tasks over the Internet. Typically, bots perform tasks that are both simple and structurally repetitive, at a much higher rate than would be possible for a human alone.</p>
                <p>&mdash; <a href="https://en.wikipedia.org/wiki/Internet_bot">Wikipedia</a></p>
            </div>
        </div>
        <div class="col-sm-12 col-md-6"><a class="screenshot" href="/bot/congressedits"><img loading="lazy" class="img-thumbnail" src="/wp-content/uploads/2018/02/congressedits.png" alt="Congress edits Wikipedia"></a></div>
    </div>
</blockquote>
<blockquote>
    <p>Bunch of Twitter usernames that are not controlled by people, but are just robots that are programmed to release the information related to all these different things. <strong>And that&rsquo;s really interesting.</strong></p>
    <p>&mdash; <a href="https://www.youtube.com/watch?v=_MKcBahA-i4">A user experience tester</a></p>
</blockquote>
<p>In essence, an online bot is a program (sometimes simple, sometimes more complex) that does something a human would otherwise do, like post pictures on <a href="https://www.tumblr.com/">Tumblr</a> or <a href="https://twitter.com/">retweet</a> Tweets about cats.</p>
<div class="row">
    <div class="col-sm-12 col-md-6">
        <div>
            <p>Bots can be funny, useful, artistic &mdash; but also annoying and spammy. This site, and our <a href="https://botmakers.org/">Botmakers</a> community, are dedicated to the friendlier kind.</p>
            <p>Feel free to browse the bots below &mdash; <a href="#browse-bots-by-category">by category</a> or <a href="#browse-bots-by-network">by the network</a> on which they operate, check out the <a href="/resources/">botmaking resources</a>, <a href="/learn/">articles</a>, or see <a href="/new">what&rsquo;s new on Botwiki</a>.</p>
        </div>
    </div>
    <div class="col-sm-12 col-md-6">
        <blockquote class="twitter-tweet" style="margin-top: 0;" data-lang="en">
            <p dir="ltr" lang="en">Apparently botmaking attracts a lot of academics, artists, and terrifyingly creative people. WHO KNEW.</p>
            <p>&mdash; emma winston &#9732; (@deer_ful) <a href="https://twitter.com/deer_ful/status/694964643710771200">February 3, 2016</a></p>
        </blockquote>
    </div>
</div>

<h4 id="browse-bots-by-category"><a class="pilcrow-link" href="#browse-bots-by-category"><span class="link">Browse by category</span><span class="pilcrow">&para;</span></a></h4>
<div class="mt-5">
    <div class="row list">
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=generative"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/thetinySAURS.png" src="/wp-content/uploads/2018/02/thetinySAURS.png" alt="@thetinySAURS"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=generative">Generative bots</a></h5>
                    <p class="card-text">Bots that make things.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=images"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/catsnacks.png" src="/wp-content/uploads/2018/02/catsnacks.png" alt="@catsnacks"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=images">Image bots</a></h5>
                    <p class="card-text">Bots posting images.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=gif"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/NixieBot.png" src="/wp-content/uploads/2018/02/NixieBot.png" alt="@NixieBot"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=gif">GIF bots</a></h5>
                    <p class="card-text">Bots posting animated GIFs.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=emoji"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/tiny_forests.png" src="/wp-content/uploads/2018/02/tiny_forests.png" alt="@tiny_forests"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=emoji">Emoji &#10024; bots</a></h5>
                    <p class="card-text">&#129302;&#128187;&#128190;</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=space"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/05/FermiPasteladox.png" src="/wp-content/uploads/2018/05/FermiPasteladox.png" alt="@FermiPasteladox"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=space">Space bots</a></h5>
                    <p class="card-text">The final frontier!</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=poetry"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/poem_exe.png" src="/wp-content/uploads/2018/02/poem_exe.png" alt="@poem_exe"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=poetry">Poetry bots</a></h5>
                    <p class="card-text">Bots that write and collect poetry.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100"><a href="/bot?tags=interactive"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/04/EmojiTetra.png" src="/wp-content/uploads/2018/04/EmojiTetra.png" alt="@EmojiTetra"></a>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=interactive">Interactive bots</a></h5>
                    <p class="card-text">Bots that you can interact with.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=interactive,game"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/letsplaysnake.png" src="/wp-content/uploads/2018/02/letsplaysnake.png" alt="@letsplaysnake"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=interactive,game">Game bots</a></h5>
                    <p class="card-text">These bots are all fun and games.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=wikipedia"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/needsref.png" src="/wp-content/uploads/2018/02/needsref.png" alt="@needsref"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=wikipedia">Wikipedia bots</a></h5>
                    <p class="card-text">Bots powered by Wikipedia, the free encyclopedia.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bots/non-english/"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/JeuDuDicoBot.png" src="/wp-content/uploads/2018/02/JeuDuDicoBot.png" alt="@JeuDuDicoBot"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bots/non-english/">Non-English bots</a></h5>
                    <p class="card-text"><em>Est-ce que votre</em> bot <em>parle fran&ccedil;ais?</em></p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot?tags=iot"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/buoypix.png" src="/wp-content/uploads/2018/02/buoypix.png" alt="@buoypix"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot?tags=iot">IoT bots</a></h5>
                    <p class="card-text">&ldquo;Internet of things&rdquo; bots, practically robots!</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?programing_language=tracery"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2019/11/artistic-intentions.png" src="/wp-content/uploads/2019/11/artistic-intentions.png" alt="Artistic Intentions"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?programing_language=tracery">Tracery bots</a></h5>
                    <p class="card-text">Bots made with Kate Compton&rsquo;s Tracery.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bots/open-source/"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/twit-code.png" src="/wp-content/uploads/2018/02/twit-code.png" alt="Twitter bot code"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bots/open-source/">Open-source bots</a></h5>
                    <p class="card-text">Bots you can use to make more bots.</p>
                </div>
            </div>
        </div>
<p><!--


<div class="col-sm-12 col-md-6 col-lg-4 list-item">


<div class="card w-100">

<a href="/bot?tags=political"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/congressedits.png" alt="Political bot" src="/wp-content/uploads/2018/02/congressedits.png" alt="Political bots" /></a>


<div class="card-body">


<h5 class="card-title"><a href="/bot?tags=political">Political bots</a></h5>




<p class="card-text">Bots with an agenda.</p>



</div>


</div>


</div>


--></p>
<div class="col-sm-12 col-md-6 col-lg-4 list-item">
    <div class="card w-100">
        <p><a href="/bot?tags=mbc-winner"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/monthly-bot-challenge-promo-2016-v2.png" al src="/wp-content/uploads/2018/02/monthly-bot-challenge-promo-2016-v2.png" alt="Monthly Bot Challenge"></a></p>
        <div class="card-body">
            <h5 class="card-title"><a href="/bot?tags=mbc-winner">Monthly Bot Challenge winners</a></h5>
            <p class="card-text">The best of the best.</p>
        </div>
    </div>
</div>
</div>
</div>
<h4 id="browse-bots-by-network"><a class="pilcrow-link" href="#browse-bots-by-network"><span class="link">Browse by network</span><span class="pilcrow">&para;</span></a></h4>
<div class="mt-5">
    <div class="row list">
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bots/twitterbots/"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/emoji__polls-v3.png" src="/wp-content/uploads/2018/02/emoji__polls-v3.png" alt="@emoji__polls"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bots/twitterbots/">Twitter bots</a></h5>
                    <p class="card-text">Bots posting on Twitter.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bots/fediverse-bots/"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/07/pkmnbattle.png" src="/wp-content/uploads/2018/07/pkmnbattle.png" alt="pkmnbattle"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bots/fediverse-bots/">Fediverse bots</a></h5>
                    <p class="card-text">Bots for Mastodon, GNU Social, and other Fediverse networks.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=tumblr-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/reverseocr.png" src="/wp-content/uploads/2018/02/reverseocr.png" alt="reverseocr"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=tumblr-bots">Tumblr bots</a></h5>
                    <p class="card-text">Bots posting on Tumblr.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=reddit-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/NobodyDoesThis.png" src="/wp-content/uploads/2018/02/NobodyDoesThis.png" alt="/u/NobodyDoesThis"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=reddit-bots">Reddit bots</a></h5>
                    <p class="card-text">Bots posting on Reddit.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bots/fediverse-bots/"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2019/11/dungeon-deployer-1.png" src="/wp-content/uploads/2019/11/dungeon-deployer-1.png" alt="dungeon-deployer"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=discord">Discord bots</a></h5>
                    <p class="card-text">Bots for Discord.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=facebook-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/asciibot.png" src="/wp-content/uploads/2018/02/asciibot.png" alt="ASCII Bot"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=facebook-bots">Facebook bots</a></h5>
                    <p class="card-text">Automated Facebook pages.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=facebook-messenger-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/retrolemonade.png" src="/wp-content/uploads/2018/02/retrolemonade.png" alt="retrolemonade"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=facebook-messenger-bots">Facebook Messenger bots</a></h5>
                    <p class="card-text">Bots on Facebook&rsquo;s Messenger app.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=youtube-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/Treasure_Column.png" src="/wp-content/uploads/2018/02/Treasure_Column.png" alt="Treasure Column"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=youtube-bots">YouTube bots</a></h5>
                    <p class="card-text">Bots that post videos on YouTube.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=slack-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/doorbell-server.png" src="/wp-content/uploads/2018/02/doorbell-server.png" alt="doorbell-server"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=slack-bots">Slack bots</a></h5>
                    <p class="card-text">Bots for Slack.</p>
                </div>
            </div>
        </div>
        <div class="col-sm-12 col-md-6 col-lg-4 list-item">
            <div class="card w-100">
                <p><a href="/bot/?networks=aim-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/SmarterChild.png" src="/wp-content/uploads/2018/02/SmarterChild.png" alt="SmarterChild"></a></p>
                <div class="card-body">
                    <h5 class="card-title"><a href="/bot/?networks=aim-bots">AIM bots</a></h5>
                    <p class="card-text">Bots that used to post on AIM.</p>
                </div>
            </div>
        </div>
<p><!--


<div class="col-sm-12 col-md-6 col-lg-4 list-item">


<div class="card w-100">
<a href="/bot/?networks=kik-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/spotify.png" alt="Spotif" src="/wp-content/uploads/2018/02/spotify.png" alt="Spotify" /></a>


<div class="card-body">


<h5 class="card-title">"card-text">Bots Kik bots</a></h5>




<p class="card-text">Bots posting on Kik.</p>



</div>


</div>


</div>


--></p>
<div class="col-sm-12 col-md-6 col-lg-4 list-item">
    <div class="card w-100">
        <p><a href="/bot/?networks=snapchat-bots"><img loading="lazy" class="lazy-load card-img-top" data-src="/wp-content/uploads/2018/02/hypem.png" src="/wp-content/uploads/2018/02/hypem.png" alt="Hype Machine"></a></p>
        <div class="card-body">
            <h5 class="card-title"><a href="/bot/?networks=snapchat-bots">Snapchat bots</a></h5>
            <p class="card-text">Bots posting on Snapchat.</p>
        </div>
    </div>
</div>
</div>
</div>



<figure class="wp-block-embed-twitter aligncenter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">bots are always there in dark times</p>&mdash; Sarah Davis Baker &#127987;&#65039;&zwj;&#127752; (@sdavbaker) <a href="https://twitter.com/sdavbaker/status/793827299808260096?ref_src=twsrc%5Etfw">November 2, 2016</a></blockquote>
</div></figure>



<div class="video-background">
    <div class="video-wrapper"><iframe loading="lazy" src="https://www.youtube.com/embed/ZtWTUt2RZh0" width="420" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></div>
</div>
</body></html>

            <br class="clear">
                                                    <h3 id="blog">Latest from the blog</h3>
                <div id="blog-latest-wrapper" class="row list">
                                  <div class="col-sm-6 col-md-6 col-lg-3 list-item">
                    <div class="card w-100">
                      <div class="overflow-hidden" style="">
                        <a href="https://botwiki.org/blog/poll-do-botmakers-put-their-bots-on-their-resume/">
                          <img loading="lazy" class="lazy-load card-img-top" src="https://botwiki.org/wp-content/uploads/2021/04/bots-resume-250x135.png"  data-src="https://botwiki.org/wp-content/uploads/2021/04/bots-resume.png" alt="Poll: Do botmakers put their bots on their resume?">
                        </a>
                      </div>
                      <div class="card-body">
                        <h5 class="card-title">
                          <a href="https://botwiki.org/blog/poll-do-botmakers-put-their-bots-on-their-resume/">Poll: Do botmakers put their bots on their resume?</a>  
                        </h5>
                        <p class="card-text">Can bots help you land a job?</p>
                      </div>
                    </div>
                  </div>
                                  <div class="col-sm-6 col-md-6 col-lg-3 list-item">
                    <div class="card w-100">
                      <div class="overflow-hidden" style="">
                        <a href="https://botwiki.org/blog/subscribe-to-our-weekly-digest/">
                          <img loading="lazy" class="lazy-load card-img-top" src="https://botwiki.org/wp-content/uploads/2021/04/botwiki-weekly-email-digest-250x135.png"  data-src="https://botwiki.org/wp-content/uploads/2021/04/botwiki-weekly-email-digest.png" alt="Subscribe to our weekly digest">
                        </a>
                      </div>
                      <div class="card-body">
                        <h5 class="card-title">
                          <a href="https://botwiki.org/blog/subscribe-to-our-weekly-digest/">Subscribe to our weekly digest</a>  
                        </h5>
                        <p class="card-text">Stay on top of the latest content with our weekly digest!</p>
                      </div>
                    </div>
                  </div>
                                  <div class="col-sm-6 col-md-6 col-lg-3 list-item">
                    <div class="card w-100">
                      <div class="overflow-hidden" style="">
                        <a href="https://botwiki.org/blog/new-twitter-list-bots-that-help-you-keep-track-of-the-day-of-the-week/">
                          <img loading="lazy" class="lazy-load card-img-top" src="https://botwiki.org/wp-content/uploads/2021/03/twitter-bots-day-of-the-week-250x135.jpeg"  data-src="https://botwiki.org/wp-content/uploads/2021/03/twitter-bots-day-of-the-week.jpeg" alt="New Twitter list: bots that help you keep track of the day of the week">
                        </a>
                      </div>
                      <div class="card-body">
                        <h5 class="card-title">
                          <a href="https://botwiki.org/blog/new-twitter-list-bots-that-help-you-keep-track-of-the-day-of-the-week/">New Twitter list: bots that help you keep track of the day of the week</a>  
                        </h5>
                        <p class="card-text">Featuring fan favorites @thursaconcept and @CraigWeekend.</p>
                      </div>
                    </div>
                  </div>
                                  <div class="col-sm-6 col-md-6 col-lg-3 list-item">
                    <div class="card w-100">
                      <div class="overflow-hidden" style="">
                        <a href="https://botwiki.org/blog/botwiki-submission-guidelines/">
                          <img loading="lazy" class="lazy-load card-img-top" src="https://botwiki.org/wp-content/uploads/2021/03/botwiki-submission-guidelines-250x135.png"  data-src="https://botwiki.org/wp-content/uploads/2021/03/botwiki-submission-guidelines.png" alt="Botwiki Submission Guidelines">
                        </a>
                      </div>
                      <div class="card-body">
                        <h5 class="card-title">
                          <a href="https://botwiki.org/blog/botwiki-submission-guidelines/">Botwiki Submission Guidelines</a>  
                        </h5>
                        <p class="card-text">Making the bot submission process more transparent.</p>
                      </div>
                    </div>
                  </div>
                                </div>
                <p><a class="btn" href="/blog/">Visit the blog</a></p>                
                    </article>
        <!-- /article -->
        <div id="botwiki-support-prompt" class="container pl-0 pr-0">
  <div class="card mt-lg-4 mb-4 pl-0 pr-0">
    <div class="card-body mt-4">
      <div class="row">
        <div class="col-sm-12">
          <h3 class="mt-0 mb-3 d-inline">Enjoying Botwiki?</h3>
          <p class="mt-4 mb-4"><strong>Consider supporting the project!</strong></p>
          <ul class="btn-list mt-2 mb-2">
            <li>
              <a class="btn mb-2" title="Support via Patreon" rel="me" href="https://www.patreon.com/botwiki">Become a patron</a>
            </li>
            <li>
              <a class="btn mb-2" title="Donate via PayPal" rel="me" href="https://paypal.me/stefanbohacek">Donate</a>
            </li>
            <li> 
              <a class="btn mb-2" title="View list of supporters" href="https://botwiki.org/about/supporters/">See our supporters</a>
            </li> 
            <li>  
              <a class="btn mb-2" title="Twitter" rel="me" href="https://twitter.com/botwikidotorg">Follow @botwikidotorg</a> 
            </li> 
          </ul>
        </div>
      </div>
    </div>
  </div>
</div>      		  </main>
      <div class="bottom-page-links">
        <ul>
          <li>
            <a id="back-to-top" title="Go back all the way to the top of this page" href="#header" class="slide-down"><img src="https://botwiki.org/wp-content/themes/botwiki/images/icons/arrow-up.svg"></a>
          </li>
          <li>
            <a id="whats-new" title="See what's new on Botwiki" href="/new/">✨</a>
          </li>
          <li>
            <a id="random-bot-link" title="Explore the wonderful world of online bots, one random bot at a time" href="https://botwiki.org/random-bot/">🤖</a>
          </li>
          <li>
            <a id="contribute-link" title="Contribute to Botwiki" href="https://botwiki.org/contribute/">📋</a>
          </li>
          <li>
            <a id="twitter-link" title="Follow @botwikidotorg on Twitter" rel="me" href="https://twitter.com/botwikidotorg">
              <img src="https://botwiki.org/wp-content/themes/botwiki/images/icons/twitter-white.svg">
              <span>@botwikidotorg</span>
            </a>
          </li>
        </ul>
      </div>
            <!-- footer -->
      <footer class="footer mt-3 mb-0 pt-3" role="contentinfo">
        <div class="container-fluid pt-5 pb-1 pl-0 pr-0 background-alternate">
          <div class="container pt-5">
            <div class="row">
              <div class="col-12">
                <div class="share-prompt">
                                    <ul class="sharing-is-caring">
                    <li>
                    <a href="https://twitter.com/intent/tweet?source=https%3A%2F%2Fbotwiki.org%2Fbots&amp;text=Bots+on+Botwiki%20https%3A%2F%2Fbotwiki.org%2Fbots&amp;via=botwikidotorg" target="_blank" title="Tweet"><img alt="Tweet" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/twitter.svg"></a>
                    </li>
                    <li>
                    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbotwiki.org%2Fbots" target="_blank" title="Share on Facebook"><img alt="Share on Facebook" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/facebook.svg"></a>
                    </li>
                    <li>
                    <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbotwiki.org%2Fbots&amp;description=Bots+on+Botwiki" target="_blank" title="Pin on Pinterest"><img alt="Pin on Pinterest" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/pinterest.svg"></a>
                    </li>
                    <li>
                    <a href="https://www.reddit.com/submit?url=https%3A%2F%2Fbotwiki.org%2Fbots&amp;title=Bots+on+Botwiki" target="_blank" title="Post on Reddit"><img alt="Post on Reddit" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/reddit.svg"></a>
                    </li>
                    <li>
                    <a href="mailto:?subject=Bots+on+Botwiki&amp;body=Botwiki is a collection of useful, friendly, and artistic online bots, and resources for making them.:%20https%3A%2F%2Fbotwiki.org%2Fbots" target="_blank" title="Send an email"><img alt="Send an email" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/email.svg"></a>
                    </li><li>
                    <a href="https://getpocket.com/save?url=https%3A%2F%2Fbotwiki.org%2Fbots&amp;title=Bots+on+Botwiki" target="_blank" title="Add to Pocket"><img alt="Add to Pocket" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/pocket.svg"></a>
                    </li>
                    <li>
                    <a href="https://pinboard.in/popup_login/?url=https%3A%2F%2Fbotwiki.org%2Fbots&amp;title=Bots+on+Botwiki&amp;description=Botwiki is a collection of useful, friendly, and artistic online bots, and resources for making them." target="_blank" title="Save to Pinboard"><img alt="Save to Pinboard" src="https://botwiki.org/wp-content/themes/botwiki/images/sharing-icons/pinboard.svg"></a>
                    </li>
                  </ul>
                  <p class="ssbg-attribution">Sharing buttons by <a href="https://simplesharingbuttons.com/">simplesharingbuttons.com</a></p>
                  <p>Botwiki is a personal side project that's made possible <a href="/about/support-us/">through donations</a> and <a href="/about/team/">hard work and dedication</a>. Huge thanks to <a href="/about/supporters/">everyone who helped us out</a>! 🙌</p>
                </div>
              </div>
            </div>
          </div>                  
        </div>
        <div class="container-fluid pt-0 pb-1 pl-0 pr-0 background-alternate">
          <div class="container">
            <div class="row">
              <div class="col-12">
               <div class="row mt-0 mb-3 ml-n3 mr-n3">
                  <div class="col-sm-12 col-md-4">
                    <ul class="footer-list">
                      <li class="list-header">About</li>
                      <li><a href="https://botwiki.org/about/">About Botwiki</a></li>
                      <li><a href="https://botwiki.org/about/projects/">Our projects</a></li>
                      <li><a href="https://botwiki.org/projects/botwiki-browser-extension/">Browser Extension</a></li>
                      <li><a href="https://botwiki.org/about/press/">Press</a></li>
                      <li><a href="https://botwiki.org/coc/">Code of Conduct</a></li>
                    </ul>                
                  </div>
                  <div class="col-sm-12 col-md-4">
                    <ul class="footer-list">
                      <li class="list-header">Contact</li>
                      <li><a class="h-card" rel="me" href="https://twitter.com/botwikidotorg">@botwikidotorg</a></li>
                      <li><a class="u-email" rel="me" href="mailto:stefan@botwiki.org">Email us</a></li>
                      <li><a href="https://botwiki.org/about/feedback">Give feedback</a></li>
                      <li><a href="https://botwiki.org/contribute/" title="Add your bot, tutorial, and other botmaking resources to Botwiki">Contribute</a></li>
                      <li><a href="https://botmakers.org/">Join Botmakers</a></li>
                    </ul>                
                  </div>
                  <div class="col-sm-12 col-md-4">
                    <ul class="footer-list">
                      <li class="list-header">Support us</li>
                      <li><a href="https://botwiki.org/about/support-us">Support us</a></li>
                      <li><a href="https://www.patreon.com/botwiki">Patreon</a></li>
                      <li><a href="https://www.paypal.me/stefanbohacek">PayPal</a></li>
                      <!-- <li><a href="/merch">Botwiki Store</a></li> -->
                      <li><a href="https://botwiki.org/about/supporters">Our supporters</a></li>
                    </ul>                
                  </div>
                </div>
              </div>
            </div>
          </div>
        </div>
        <div class="container-fluid pt-0 pb-4 pl-0 pr-0 background-alternate">
          <div class="container">
            <div class="row">
              <div class="col-12 pt-3 pb-5">
                <p>This website is <a href="https://github.com/botwiki/botwiki-wp-theme">open source</a> and powered by <a href="https://wordpress.org" title="WordPress">WordPress</a>. Botwiki and the <a href="http://botzine.org/">Bot! zine</a> and <a href="https://botmakers.org/">Botmakers</a> landing pages are all proudly hosted by <a href="https://digitalocean.com/"><img class="footer-logo-do" src="https://botwiki.org/wp-content/themes/botwiki/images/logos/digitalocean.svg"></a>, a generous supporter and the sponsor of the very first <a href="https://botwiki.org/monthly-bot-challenge/">Monthly Bot Challenge</a>.</p>
                <p>One more way to support us is to sign up using our <a href="https://www.digitalocean.com/?refcode=9e279abc3337">DigitalOcean referral link</a>, which will also earn you a $10 starter credit.</p>
                <p>For attributions, see the <a href="https://botwiki.org/about/attributions">Attributions page</a>.</p>
              </div>
            </div>
          </div>
        </div>
        <div class="container mb-5 pb-3">
          <div class="row align-items-center mx-auto mt-5 mb-5">
            <div class="col-sm-12 mx-auto mt-4 text-center">
              <p class="d-inline text-center">
                <a href="https://fightfascism.glitch.me/">
                  <img loading="lazy" class="m-2 lazy-load" alt="Fight Fascism" title="Fight fascism! Design by Angus Johnston" src="https://botwiki.org/wp-content/themes/botwiki/images/other/fight-fascism-square.png" data-src="https://botwiki.org/wp-content/themes/botwiki/images/other/fight-fascism-square.png">
                </a>
              </p>
              <p class="d-inline text-center">
                <a href="https://blacklivesmatter.com/">
                  <img loading="lazy" class="m-2 lazy-load" alt="Black Lives Matter" title="Black Lives Matter logo" src="https://botwiki.org/wp-content/themes/botwiki/images/other/blm.png" data-src="https://botwiki.org/wp-content/themes/botwiki/images/other/blm.png">
                </a>
              </p>
              <p class="d-inline text-center">
                <a href="https://indieweb.org/">
                  <img loading="lazy" class="m-2 lazy-load" alt="IndieWeb" title="Support #indieweb!" src="https://botwiki.org/wp-content/themes/botwiki/images/other/indiewebcamp-black.png" data-src="https://botwiki.org/wp-content/themes/botwiki/images/other/indiewebcamp-black.png">
                </a>
              </p>              
            </div>
          </div>
        </div>
      </footer>
    <!-- /footer -->    
    <!-- analytics -->
    <script type="text/javascript">
    var sc_project=10530872; 
    var sc_invisible=1; 
    var sc_security="b852d106"; 
    </script>
    <script type="text/javascript"
    src="https://www.statcounter.com/counter/counter.js"
    async></script>
    <noscript><div class="statcounter"><a title="Web Analytics"
    href="https://statcounter.com/" target="_blank"><img
    class="statcounter"
    src="https://c.statcounter.com/10530872/0/b852d106/1/"
    alt="Web Analytics"></a></div></noscript>
    <script type="text/javascript" >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</script><script type='text/javascript' id='ftf-ate-frontend-js-js-extra'>
/* <![CDATA[ */
var ftf_aet = {"ajax_url":"https:\/\/botwiki.org\/wp-admin\/admin-ajax.php","config":{"show_metrics":true,"use_api":true}};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-content/plugins/tembeds/dist/js/scripts.min.js?ver=1620248897' id='ftf-ate-frontend-js-js'></script>
<script type='text/javascript' defer="defer" src='https://botwiki.org/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
.
  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 13/171 objects using memcached
Page Caching using memcached 
Database Caching 2/42 queries in 0.019 seconds using memcached

Served from: botwiki.org @ 2021-05-07 20:15:08 by W3 Total Cache
-->